您的位置:首页 > 其它

poj 2780 Linearity

2011-11-22 13:09 197 查看
Linearity

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 6722Accepted: 1499
Description

Alice often examines star maps where stars are represented by points in a plane and there is a Cartesian coordinate for each star. Let the Linearity of a star map be the maximum number of stars in a straight line.



For example, look at the star map shown on the figure above, the Linearity of this map is 3, because the star 1, star 2, and star 5 are within the same straight line, and there is no straight line that passes 4 stars.

You are to write a program to find the Linearity of a star map.
Input

Input will contain multiple test cases. Each describes a star map.

For each test case, the first line of the input contains the number of stars N (2 <= N <= 1000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0 <= X, Y <= 1000). There can be only one star at one point of the plane.
Output

Output the Linearity of the map in a single line.
Sample Input

5
0 0
2 0
0 2
1 1
2 2

Sample Output

3


#include<iostream>
#include<algorithm>
using namespace std;

double k[1002];
double x[1002],y[1002];

int main()
{
int n;
int i,j,p;
int cnt;
int num,max_num;
while(cin>>n)
{
for(i=0;i<n;i++)
{
cin>>x[i];
cin>>y[i];
}
num=2;
max_num=2;
for(i=0;i<n;i++)
{
cnt=0;
for(j=0;j<n;j++)
{
if(i==j)
continue;
if(x[i]==x[j])
k[cnt]=999999999;
else
{
k[cnt]=(y[i]-y[j])/(x[i]-x[j]);
}
cnt++;
}
sort(k,k+cnt);
num=2;
for(p=1;p<cnt;p++)
{
if(k[p]==k[p-1])
{
num++;
if(max_num<num)
max_num=num;
}
else
{
num=2;
if(max_num<num)
max_num=num;
}
}
}
cout<<max_num<<endl;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: