您的位置:首页 > 其它

poj 1969 Count on Canton

2011-11-21 23:27 274 查看
Count on Canton

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 8107Accepted: 4733
Description

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

1/1 1/2 1/3 1/4 1/5 ...

2/1 2/2 2/3 2/4

3/1 3/2 3/3

4/1 4/2

5/1


In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.
Input

The input list contains a single number per line and will be terminated by endof-file.
Output

You are to write a program that will read a list of numbers in the range from 1 to 10^7 and will print for each number the corresponding term in Cantor's enumeration as given below.
Sample Input

3
14
7

Sample Output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4


#include <iostream>
using namespace std;
int main()
{
int n,flag,position;
while (cin >> n)
{
flag=0;
position=n;
while (n>flag)//定位,确定分子分母
{
n-=flag;
flag++;
}
if (flag%2==0)
cout << "TERM " <<position << " IS "<<n<<"/" << flag-n+1<< endl;
else
cout << "TERM " <<position << " IS "<<flag-n+1<<"/" << n << endl;
}
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: