您的位置:首页 > 其它

poj1032 Parliament

2011-11-21 09:19 302 查看
Parliament

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 13632Accepted: 5722
Description

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.
Input

The input file contains a single integer N (5<=N<=1000 ).
Output

Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.
Sample Input

7

Sample Output

3 4


#include <iostream>
using namespace std;
int main()
{
int n,i=4,m=5,j;
scanf("%d",&n);
while (m<n)
m+=i++;
j=m-n;
m=2;
if (j==1)
{
m=3;
j=i-1;
i++;
}
while (m<i-1)
{
if (m!=j)
printf("%d ",m);
m++;
}
printf("%d\n",i-1);
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: