您的位置:首页 > 其它

Digital Library 字符数组操作

2011-10-18 21:33 162 查看




1022. Digital Library (30)

时间限制

1000 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from
a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;

Line #2: the book title -- a string of no more than 80 characters;

Line #3: the author -- a string of no more than 80 characters;

Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;

Line #5: the publisher -- a string of no more than 80 characters;

Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

1: a book title

2: name of an author

3: a key word

4: name of a publisher

5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found


思路:这题看起来很复杂,主要是考察字符串的操作,尤其注意字符数组的输入方式选择。

对于 char a[10],①cin>>a;②cin.getline(a,6);③gets(a);④cin.get(a,6);
若输入"abcd efgh ijkl"回车对应一下结果:
①a[]={'a','b','c','d','\0'} strlen(a)=4 ; sizeof(a)=10 //遇到空格、制表符、回车即停止
②④a[]={[b]'a','b','c','d',' ','\0'} strlen(a)=5
; sizeof(a)=10 //遇到回车停止
[/b]
③a[]={[b][b]'a','b','c','d',' ','e','f','g','h',' ','i','j','k','l'[/b]}
strlen(a)=14 ; sizeof(a)=10 //溢出错误[/b]


[b]在使用cin>>a或cin>>n后,想要使用gets(a)或cin.getline(a,n) 需要先使用cin.ignore()忽略掉空格和回车。[/b]
[b]使用ch=cin.get()或cin.get(ch)获取一个字符(可用来寻找回车符'\n')。[/b]

代码如下:

#include <iostream>
#include <memory.h>
#include <algorithm>
using namespace std;

struct String
{
char s[11];
String *next;
String(){next=0;}
}*str;

struct Book
{
char id[8];
char title[81];
char author[81];
String *keyword;
char publisher[81];
char pubYear[5];
Book(){keyword=0;}
}*book;

int n;

bool cmp(Book a,Book b)
{
if(strcmp(a.id,b.id)>0)return false;
else return true;
}

void query(char *c)
{
int i;
bool flag=false;
bool notFound=true;
for(i=0;i<n;i++)
{
if(strcmp(c,book[i].title)==0)flag=true;
else if(strcmp(c,book[i].author)==0)flag=true;
else if(strcmp(c,book[i].publisher)==0)flag=true;
else if(strcmp(c,book[i].pubYear)==0)flag=true;
else
{
str=book[i].keyword;
while(str)
{
if(strcmp(c,str->s)==0){flag=true;break;}
str=str->next;
}
}
if(flag){cout<<book[i].id<<endl;flag = false;notFound=false;}
}
if(notFound)cout<<"Not Found"<<endl;
}

int main()
{
freopen("in.txt","r",stdin);

cin>>n;
book=(Book *)malloc(sizeof(Book)*n);
memset(book,0,sizeof(Book)*n);           //主要是为让keyword清零

cin.ignore();     //忽略n后面的回车符

char key[11];

int m,i;

for(i=0;i<n;i++)
{
gets(book[i].id);
gets(book[i].title);
gets(book[i].author);
while(cin>>key)
{
str=new String;
strcpy(str->s,key);
str->next=book[i].keyword;
book[i].keyword=str;
if(cin.get()=='\n')break;   //判断是否为回车符,表示关键字结束 //没有cin.getchar()
}
//	getline(cin,book[i].keyword);
gets(book[i].publisher);
gets(book[i].pubYear);
}
sort(book,book+n,cmp);
cin>>m;
char num[3];
char search[81];
for(i=0;i<m;i++)
{
cin>>num;
cin.ignore();       //忽略回车符
gets(search);
cout<<num<<" "<<search<<endl;
query(search);
}
return 0;
}


此题编译后结果“部分正确”得到25分,其中有一个case超时错误,系统标准模板库sort函数采用的是快速排序算法。还不清楚是哪里效率有待提高,就先放在这里了。

优化的思路:

为每一个title、author、publisher、keyword、year都建立一个map映射表,其value为vector类型,用于存储多个Id。

代码:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <string>
#include <iomanip>
#include <map>
#include <cstring>
#include <sstream>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

int main()
{
int n;
cin>>n;
int i;
int id,year;
char ch;
string title,author,publisher;
string keyword;
stringstream ss;

map<string,vector<int>> titleMap;
map<string,vector<int>> authorMap;
map<string,vector<int>> keywordMap;
map<string,vector<int>> publisherMap;
map<int,vector<int>> yearMap;

typedef map<string,vector<int>>::iterator itType;
itType it;
typedef map<int,vector<int>>::iterator yearItType;
yearItType yearIt;

for(i=0;i<n;i++){
cin>>id;
cin.ignore();
getline(cin,title,'\n');

it = titleMap.find(title);
if(it != titleMap.end()){
it->second.push_back(id);
}else{
vector<int> vec;
vec.push_back(id);
titleMap.insert(make_pair(title,vec));
}

getline(cin,author,'\n');
it = authorMap.find(author);
if(it != authorMap.end()){
it->second.push_back(id);
}else{
vector<int> vec;
vec.push_back(id);
authorMap.insert(make_pair(author,vec));
}

getline(cin,keyword,'\n');
ss.clear();
ss << keyword;

while(ss >> keyword){
it = keywordMap.find(keyword);
if(it != keywordMap.end()){
it->second.push_back(id);
}else{
vector<int> vec;
vec.push_back(id);
keywordMap.insert(make_pair(keyword,vec));
}
}

getline(cin,publisher,'\n');
it = publisherMap.find(publisher);
if(it != publisherMap.end()){
it->second.push_back(id);
}else{
vector<int> vec;
vec.push_back(id);
publisherMap.insert(make_pair(publisher,vec));
}

cin>>year;
yearIt = yearMap.find(year);
if(yearIt != yearMap.end()){
yearIt->second.push_back(id);
}else{
vector<int> vec;
vec.push_back(id);
yearMap.insert(make_pair(year,vec));
}
}

int num,j;
cin>>num;
char style[4];
string words;
for(i=0;i<num;i++){
cin>>style;
cin.ignore();
getline(cin,words,'\n');
vector<int> vec;
switch(style[0]){
case '1':
it = titleMap.find(words);
if(it!=titleMap.end()){
vec = it->second;
}
break;
case '2':
it = authorMap.find(words);
if(it!=authorMap.end()){
vec = it->second;
}
break;
case '3':
it = keywordMap.find(words);
if(it!=keywordMap.end()){
vec = it->second;
}
break;
case '4':
it = publisherMap.find(words);
if(it!=publisherMap.end()){
vec = it->second;
}
break;
case '5':
year = atoi(words.c_str());
yearIt = yearMap.find(year);
if(yearIt!=yearMap.end()){
vec = yearIt->second;
}
break;
}
cout<<style<<" "<<words<<endl;
if(vec.size() == 0){
cout<<"Not Found"<<endl;
continue;
}
sort(vec.begin(),vec.end());
for(j=0;j<vec.size();j++){
cout<<setw(7)<<setfill('0')<<vec[j]<<endl;
}
}

system( "PAUSE");
return 0;
}


这次AC了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: