您的位置:首页 > 其它

poj 1742 Coins(多重背包可行性问题)

2011-10-05 20:36 489 查看
Coins

Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 20885Accepted: 7128
Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change)
and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by
two zeros.

Output

For each test case output the answer on a single line.

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0


Sample Output
8
4


Source

LouTiancheng@POJ
题目:http://poj.org/problem?id=1742

分析:突然在讨论栏里看到有人说这是楼大叔的题,顿时感觉苍老了许多= =,这题很明显是多重背包,也很明显普通的多重背包必定超时,于是用倍增思想来优化,2600++ms险过阿,然后想起背包九讲里面说的O(VN)的做法,多重背包可行性,然后发现去年我已经写过了,囧。。。果断不及得了,1300++ms过了,还是有点慢,不过貌似我没办法再优化了,希望有高手指点,^_^

代码(倍增):

#include<cstdio>
using namespace std;
const int mm=111111;
const int mn=111;
int a[mn],c[mn];
bool f[mm];
int n,m;
void CompletePack(int v)
{
    for(int i=v;i<=m;++i)f[i]|=f[i-v];
}
void ZeroOnePack(int v)
{
    for(int i=m;i>=v;--i)f[i]|=f[i-v];
}
int main()
{
    int i,j,ans;
    while(scanf("%d%d",&n,&m),n+m)
    {
        for(i=0;i<n;++i)scanf("%d",&a[i]);
        for(i=0;i<n;++i)scanf("%d",&c[i]);
        for(i=f[0]=1;i<=m;++i)f[i]=0;
        for(i=0;i<n;++i)
        if(c[i])
            if(c[i]*a[i]>=m)CompletePack(a[i]);
            else
            {
                j=1;
                while(j<c[i])
                {
                    ZeroOnePack(a[i]*j);
                    c[i]-=j;
                    j<<=1;
                }
                ZeroOnePack(a[i]*c[i]);
            }
        ans=0;
        for(i=1;i<=m;++i)ans+=f[i];
        printf("%d\n",ans);
    }
    return 0;
}


代码2O(VN):

#include <cstdio>
int i,j,n,m,ans,v[100],c[100],t[100001];
bool p[100001];
int main()
{
    while(scanf("%d %d", &n, &m),n)
    {
        for(i=0;i<n;++i)scanf("%d",v+i);
        for(i=0;i<n;++i)scanf("%d",c+i);
        for(p[0]=i=1;i<=m;++i)p[i]=0;
        for(ans=i=0; i<n; ++i)
        {
            for(j=0; j<=m;++j)t[j]=0;
            for(j=v[i];j<=m;++j)
                if(!p[j]&&p[j-v[i]]&&t[j-v[i]]<c[i])t[j]=t[j-v[i]]+1,p[j]=1,++ans;
        }
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: