您的位置:首页 > 运维架构 > Shell

uva 10152 shellsort

2011-10-02 16:22 281 查看

Problem D: ShellSort

He made each turtle stand on another one's back

And he piled them all up in a nine-turtle stack.

And then Yertle climbed up. He sat down on the pile.

What a wonderful view! He could see 'most a mile!

The Problem

King Yertle wishes to rearrange his turtle throne to place his highest-ranking nobles and closest advisors nearer to the top. A single operation is available to change the order of the turtles in the stack: a turtle can crawl out of its position in the stack
and climb up over the other turtles to sit on the top.

Given an original ordering of a turtle stack and a required ordering for the same turtle stack, your job is to determine a minimal sequence of operations that rearranges the original stack into the required stack.

The first line of the input consists of a single integer K giving the number of test cases. Each test case consist on an integer n giving the number of turtles in the stack. The next n lines specify the original ordering of the
turtle stack. Each of the lines contains the name of a turtle, starting with the turtle on the top of the stack and working down to the turtle at the bottom of the stack. Turtles have unique names, each of which is a string of no more than eighty characters
drawn from a character set consisting of the alphanumeric characters, the space character and the period (`.'). The next n lines in the input gives the desired ordering of the stack, once again by naming turtles from top to bottom. Each test case
consists of exactly 2n+1 lines in total. The number of turtles (n) will be less than or equal to two hundred.

For each test case, the output consists of a sequence of turtle names, one per line, indicating the order in which turtles are to leave their positions in the stack and crawl to the top. This sequence of operations should transform the original stack into
the required stack and should be as short as possible. If more than one solution of shortest length is possible, any of the solutions may be reported. Print a blank line after each test case.

Sample Input

2
3
Yertle
Duke of Earl
Sir Lancelot
Duke of Earl
Yertle
Sir Lancelot
9
Yertle
Duke of Earl
Sir Lancelot
Elizabeth Windsor
Michael Eisner
Richard M. Nixon
Mr. Rogers
Ford Perfect
Mack
Yertle
Richard M. Nixon
Sir Lancelot
Duke of Earl
Elizabeth Windsor
Michael Eisner
Mr. Rogers
Ford Perfect
Mack

Sample Output

Duke of Earl

Sir Lancelot
Richard M. Nixon
Yertle


从号码第二大(第一大不用管)的乌龟开始。

到了第 n 号乌龟时,若他和比他大一号(n+1)的乌龟顺序正确,则 n 号乌龟不动,否则爬到顶端。

#include <cstdio>
#include <cstdlib>
#include <cassert>
#include <list>
#include <algorithm>
#include <string>

using namespace std;

struct Turtle {
int _n;
string _name;
Turtle (int n, const string &name): _n (n), _name (name) {}
};

list <Turtle> turtle;

void Solve () {
int n;
if (scanf ("%d", &n) == EOF) {
exit (0);
}
while (getchar() != '\n') {}
turtle.clear ();
char name[100];
for (int i=0; i<n; ++i) {
gets (name);
turtle.push_back (Turtle (-1, name));
}
for (int i=0; i<n; ++i) {
gets (name);
for (__typeof (turtle.begin()) k=turtle.begin(); k!=turtle.end(); ++k) {
if (k->_name == name) {
assert (k->_n == -1);
k->_n = i;
break;
}
}
}

// initialization complete, begin to sort
for (int i=1; i<n; ++i) {
int finding = n - i - 1;
list <Turtle>::iterator itPrev = turtle.end(),
itFinding = turtle.end(),
it = turtle.begin();
while (itFinding == turtle.end()) {
assert (it != turtle.end());
if (it->_n == finding) {
itFinding = it;
} else if (it->_n == finding + 1) {
itPrev = it;
}
++it;
}
if (itPrev != turtle.end()) { // turtle 'finding + 1' is not below turtle 'finding'
printf ("%s\n", itFinding->_name.c_str());
turtle.insert (turtle.begin(), *itFinding);
turtle.erase (itFinding);
}
#ifdef _DEBUG
printf ("\n");
for (list <Turtle>::iterator i=turtle.begin(); i!=turtle.end(); ++i) {
printf ("%30s, %d\n", i->_name.c_str(), i->_n);
}
printf ("\n");
#endif
}
printf ("\n");
}

int main () {
int cs;
scanf ("%d", &cs);
while (cs--) {
Solve ();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: