您的位置:首页 > 其它

poj 1976 A Mini Locomotive (DP)

2011-09-29 19:15 411 查看
A Mini Locomotive

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 1650Accepted: 897
Description

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive
can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.

2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.

3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported
by the three mini locomotives.

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:

The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the ith number of in this
line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger
coaches.

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input
1
7
35 40 50 10 30 45 60
2


Sample Output
240


Source

Tehran Sharif 2004 Preliminary

题目:http://poj.org/problem?id=1976

分析:怎么大家都说用背包来做呢?反正我看不像。。。= =,假设f[i][j]表示前i节车厢,用j个车头来拉做多能拉多少人,f[i][j]=max(f[i-1][j],f[k][j-1]+a[i]-a[k]) k=max(i-m,0),这样写的复杂度为O(n*4)。。。

代码:

#include<cstdio>
#include<iostream>
using namespace std;
int f[55555][4],a[55555];
int i,j,k,n,m,t;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        a[0]=0;
        for(i=1;i<=n;++i)scanf("%d",&a[i]),a[i]+=a[i-1];
        scanf("%d",&m);
        for(i=0;i<=n;++i)
            for(j=0;j<4;++j)f[i][j]=0;
        for(i=1;i<=n;++i)
            for(j=1;j<4;++j)
            {
                k=i-m;
                if(k<0)k=0;
                f[i][j]=max(f[i-1][j],f[k][j-1]+a[i]-a[k]);
            }
        printf("%d\n",f
[3]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: