您的位置:首页 > 其它

poj 1141【dp--记录路径】

2011-09-25 21:58 507 查看
Brackets Sequence

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16818Accepted: 4571Special Judge
Description
Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.

2. If S is a regular sequence, then (S) and [S] are both regular sequences.

3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2
... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.
Input
The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.
Output
Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.
Sample Input
([(]

Sample Output
()[()]

Source
Northeastern Europe 2001

#include <iostream>
using namespace std;

char s[102];
int dp[110][110], path[110][110];
const int inf = 0xffffff;

void output(int i, int j)
{
if (i > j)
return;
if (i == j)
{
if (s[i] == '(' || s[j] == ')') printf("()");
else printf("[]");
}
else
if (path[i][j] == -1)
{
printf("%c",s[i]);
output(i+1,j-1);
printf("%c",s[j]);
}

else
{
output(i,path[i][j]);
output(path[i][j]+1,j);
}
}

int main()
{
scanf("%s",s);
memset(dp,0,sizeof(dp));
int n = strlen(s);
for (int i = 0; i < n; ++i)
dp[i][i] = 1;

for (int p = 1; p < n; ++p)
for (int i = 0; i < n-p; ++i)
{
int j = i+p;
dp[i][j] = inf;
if ((s[i] == '(' && s[j] == ')') || (s[i] == '[' && s[j] == ']'))
if(dp[i][j]>dp[i+1][j-1])
dp[i][j]=dp[i+1][j-1],path[i][j]=-1;
for (int k = i; k < j; ++k)
{
if (dp[i][j] > dp[i][k] + dp[k+1][j])
{
dp[i][j] = dp[i][k] + dp[k+1][j];
path[i][j] = k;
}
}
}
output(0,n-1);
printf("\n");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: