您的位置:首页 > 其它

poj3630 Phone List

2011-09-23 22:25 218 查看
Phone List

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13154Accepted: 4207
Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

Emergency 911

Alice 97 625 999

Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题目大意是:给定n个只含数字的字符串,判断是否存在 其中一个字符串是否是另一个字符串的前缀 存在输出"NO" 不存在输出"YES"

WA一次有点遗憾原因是把"YES”和"NO”给搞反了

算法:按字典序排序,然后判断相邻两个字符串是否存在前缀,想到了很简单,为什么我就没想到呢,要反思!!反思!!


#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
#define N 10010
using namespace std;
string tel
;

bool judge(int n)
{
int i,k,len;
for(k=0;k<n-1;k++)
{
len=tel[k].size();//<tel[k+1].size()?tel[k].size():tel[k+1].size();
for(i=0;i<len;i++)
if(tel[k][i]!=tel[k+1][i])
break;
if(i==len) return true;
}
return false;
}

int main()
{
int t,i,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++) cin>>tel[i];
sort(tel,tel+n);
if(judge(n)) printf("NO\n");
else printf("YES\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: