您的位置:首页 > 大数据 > 人工智能

HDU/HDOJ 2855 2009 Multi-University Training Contest 5 - Host by NUDT 矩阵二分幂

2011-09-21 15:31 501 查看

Fibonacci Check-up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 615 Accepted Submission(s): 333



[align=left]Problem Description[/align]
Every ALPC has his own alpc-number just like alpc12, alpc55, alpc62 etc.

As more and more fresh man join us. How to number them? And how to avoid their alpc-number conflicted?

Of course, we can number them one by one, but that’s too bored! So ALPCs use another method called Fibonacci Check-up in spite of collision.

First you should multiply all digit of your studying number to get a number n (maybe huge).

Then use Fibonacci Check-up!

Fibonacci sequence is well-known to everyone. People define Fibonacci sequence as follows: F(0) = 0, F(1) = 1. F(n) = F(n-1) + F(n-2), n>=2. It’s easy for us to calculate F(n) mod m.

But in this method we make the problem has more challenge. We calculate the formula


, is the combination number. The answer mod m (the total number of alpc team members) is just your alpc-number.

[align=left]Input[/align]
First line is the testcase T.

Following T lines, each line is two integers n, m ( 0<= n <= 10^9, 1 <= m <= 30000 )

[align=left]Output[/align]
Output the alpc-number.

[align=left]Sample Input[/align]

2
1 30000
2 30000


[align=left]Sample Output[/align]

1
3


[align=left]Source[/align]
2009 Multi-University Training Contest 5 - Host by NUDT

有一个公式:

C(N,1)F1+C(N,2)F2+C(N,3)F3+...+C(N,N)FN=F(2N)

证明方法我有点忘了,大致是利用那个比内公式去推

n=0和1最好特判一下

我的代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>

using namespace std;

struct mart{
int mat[3][3];
};
int mod;
mart kk;

mart multi(mart a,mart b){
mart c;
int i,j,k;
for(i=1;i<=2;i++)
for(j=1;j<=2;j++)
{
c.mat[i][j]=0;
for(k=1;k<=2;k++)
c.mat[i][j]=(c.mat[i][j]%mod+(a.mat[i][k]%mod)*(b.mat[k][j]%mod)%mod)%mod;
}
return c;
}

mart power(int k){
mart p,q;
int i,j;
for(i=1;i<=2;i++)
for(j=1;j<=2;j++)
{
p.mat[i][j]=kk.mat[i][j];
if(i==j)
q.mat[i][j]=1;
else
q.mat[i][j]=0;
}
if(k==0)
return q;
while(k!=1)
{
if(k&1)
{
k--;
q=multi(p,q);
}
else
{
k=k>>1;
p=multi(p,p);
}
}
p=multi(p,q);
return p;
}

int main(){
int n,m,tt;
scanf("%d",&tt);
mart xx;
while(tt--)
{
scanf("%d%d",&n,&m);
if(n==0)
{
printf("0\n");
continue;
}
if(n==1)
{
printf("%d\n",1%m);
continue;
}
mod=m;
kk.mat[1][1]=0;
kk.mat[1][2]=1;
kk.mat[2][1]=1;
kk.mat[2][2]=1;
xx=power(2*n-1);
printf("%d\n",(xx.mat[1][1]+xx.mat[1][2])%mod);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐