您的位置:首页 > 其它

hdu 1028 Ignatius and the Princess III

2011-09-17 19:19 399 查看

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5135 Accepted Submission(s): 3609



[align=left]Problem Description[/align]
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

[align=left]Input[/align]
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

[align=left]Output[/align]
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

[align=left]Sample Input[/align]

4
10
20


[align=left]Sample Output[/align]

5
42
627  [code]#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main(  )
{
int c1[125] , c2[125] ;
for( int i = 0 ; i < 125 ; i++ )
{ c1[i] = 1 ; c2[i] = 0 ; }
for( int i = 2 ; i < 125 ; i++ )
{
for( int j = 0 ; j < 125 ; j++ )
{
for( int k = 0 ; k +j < 125 ; k+=i )
c2[k+j] += c1[j] ;
}
for( int j = 0 ; j < 125 ; j++ )
{
c1[j] = c2[j] ;
c2[j] = 0 ;
}
}
int n ;
while( scanf("%d" , &n ) != EOF )
{
printf("%d\n" , c1
) ;
}
// system( "pause" );
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: