您的位置:首页 > 其它

hust 1017 Exact cover 精确覆盖 DLX 给定一个M*N的0-1矩阵,是否能选择一些行,使每一列只有一个’1’

2011-09-15 21:31 435 查看

Description

There is an N*M matrix with only 0s and 1s, (1 <= N,M <= 1000). An exact cover is a selection of rows such that every column has a 1 in exactly one of the selected rows.

Try to find out the selected rows.

Input

There are multiply test cases.

First line: two integers N, M;

The following N lines: Every line first comes an integer C(1 <= C <= 100), represents the number of 1s in this row, then comes C integers: the index of the columns whose value is 1 in this row.

Output

First output the number of rows in the selection, then output the index of the selected rows.

If there are multiply selections, you should just output any of them.

If there are no selection, just output "NO".

Sample Input

6 7
3 1 4 7
2 1 4
3 4 5 7
3 3 5 6
4 2 3 6 7
2 2 7

Sample Output

3 2 4 6


//

#include<stdio.h>

#include<string.h>

#include<time.h>

#define N 1005

#define V 102005

int U[V],D[V];

int L[V],R[V];

int C[V];

int H
,S
,mark[V];

int size,n,m,OK
,flag;

void Link(int r,int c)

{

S[c]++;C[size]=c;

U[size]=U[c];D[U[c]]=size;

D[size]=c;U[c]=size;

if(H[r]==-1) H[r]=L[size]=R[size]=size;

else

{

L[size]=L[H[r]];R[L[H[r]]]=size;

R[size]=H[r];L[H[r]]=size;

}

mark[size]=r;

size++;

}

void remove(int c)//删除列

{

int i,j;

L[R[c]]=L[c];

R[L[c]]=R[c];

for(i=D[c];i!=c;i=D[i])

{

for(j=R[i];j!=i;j=R[j])

{

U[D[j]]=U[j],D[U[j]]=D[j];

S[C[j]]--;

}

}

}

void resume(int c)

{

int i,j;

for(i=U[c];i!=c;i=U[i])

{

for(j=L[i];j!=i;j=L[j])

{

U[D[j]]=j;D[U[j]]=j;

S[C[j]]++;

}

}

L[R[c]]=c;

R[L[c]]=c;

}

void Dance(int k)

{

int i,j,Min,c;

if(!R[0])

{

flag=1;//标记有解

printf("%d",k);

for(i=0;i<k;i++)

printf(" %d",mark[OK[i]]);

printf("\n");

return;

}

for(Min=N,i=R[0];i;i=R[i])

if(S[i]<Min) Min=S[i],c=i;

remove(c);//删除该列

for(i=D[c];i!=c;i=D[i])

{

OK[k]=i;

for(j=R[i];j!=i;j=R[j])

remove(C[j]);

Dance(k+1);

if(flag) return;//只要一组解

for(j=L[i];j!=i;j=L[j])

resume(C[j]);

}

resume(c);

}

int main()

{

int i,j,num;

while(scanf("%d%d",&n,&m)!=EOF)

{

for(i=0;i<=m;i++)

{

S[i]=0;

D[i]=U[i]=i;

L[i+1]=i;R[i]=i+1;

}R[m]=0;

size=m+1;

memset(H,-1,sizeof(H));

memset(mark,0,sizeof(mark));

for(i=1;i<=n;i++)

{

scanf("%d",&num);

while(num--)

{

scanf("%d",&j);

Link(i,j);

}

}

flag=0;

Dance(0);

if(!flag) printf("NO\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: