您的位置:首页 > 其它

poj 1250(Tanning Salon)

2011-09-15 00:02 302 查看
题意:一个旅馆有n个位,给出所有旅客到达旅馆和离开旅馆的顺序,问有多少旅客是没有住旅馆就离开的。

由于题目中告诉每个顾客只会出现一次,所以我用一个数组存储每个顾客的情况直接模拟:

Tanning Salon

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 5276Accepted: 2876
Description
Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task
is to write a program that tells the company how many customers left without tanning.

Input
The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning
beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will
occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

Output
For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input
2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output
All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.

Source
Mid-Central USA 2002

#include<cstdio>
#include<stack>
#include<iostream>
#include<cstring>

using namespace std;

string str[25];
int n,zumu[26];
char ch[70];
int main(){
while(scanf("%d", &n) && n){
memset(zumu,0,sizeof(zumu));
scanf("%s", ch);
int sum = 0;
for(int i = 0; ch[i]; i++){
if(zumu[ch[i] - 'A'] == 0 && n != 0)  {n--;zumu[ch[i] - 'A']++;}
else if(zumu[ch[i] - 'A'] == 1) {zumu[ch[i] - 'A']--;n++;}
else if(n == 0){
if(zumu[ch[i] - 'A'] == 0){
zumu[ch[i] - 'A'] = 2;
sum++;
}
}
}
if(sum == 0)  printf("All customers tanned successfully.\n");
else printf("%d customer(s) walked away.\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: