您的位置:首页 > 编程语言 > Java开发

Java程序练习-487-3279

2011-09-07 16:59 316 查看
http://poj.grids.cn/practice/1002/

487-3279

时间限制: 1000ms 内存限制: 65536kB

描述

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes
only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your
pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.
The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

输入

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory,
with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

输出

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory.
Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

样例输入

12

4873279

ITS-EASY

888-4567

3-10-10-10

888-GLOP

TUT-GLOP

967-11-11

310-GINO

F101010

888-1200

-4-8-7-3-2-7-9-

487-3279

样例输出

310-1010 2

487-3279 4

888-4567 3

参考代码

import java.io.*;
import java.util.*;
public class Main {
public static char []key;
public static void main(String[] args) throws NumberFormatException, IOException{
//Scanner cin = new Scanner(System.in);
DataInputStream cin = new DataInputStream(new BufferedInputStream(System.in));
Map<String, Integer> tm = new TreeMap<String, Integer>();
//int total = cin.nextInt();
int total =  Integer.parseInt(cin.readLine().trim());
String ts = new String();
init();
int i,j;
//cin.nextLine();
for(i = 0;i < total;++ i){
//ts = cin.nextLine().replace("-","");
ts = cin.readLine().replace("-", "");
StringBuffer sb = new StringBuffer();
for(j = 0;j < ts.length();++ j){
if(Character.isDigit(ts.charAt(j))){
sb.append(ts.charAt(j));
}
else{
sb.append(key[ts.charAt(j)]);
}
}
String result = sb.toString().substring(0,3)+"-"+sb.toString().substring(3);
if(tm.containsKey(result)){
int count = tm.get(result) + 1;
tm.put(result, count);
}else{
tm.put(result, 1);
}
}
Set<String> st = tm.keySet();
Iterator<String> it = st.iterator();
boolean duplicates = true;
while(it.hasNext()){
String s = it.next().toString();
int count = tm.get(s);
if(count > 1){
System.out.println(s+" "+count);
duplicates = false;
}
}
if(duplicates){
System.out.println("No duplicates.");
}
}
private static void init() {
key = new char[256];
key['A'] = key['B'] = key['C'] = '2';
key['D'] = key['E'] = key['F'] = '3';
key['G'] = key['H'] = key['I'] = '4';
key['J'] = key['K'] = key['L'] = '5';
key['M'] = key['N'] = key['O'] = '6';
key['P'] = key['R'] = key['S'] = '7';
key['T'] = key['U'] = key['V'] = '8';
key['W'] = key['X'] = key['Y'] = '9';
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: