您的位置:首页 > 其它

PKU ACM 1007 DNA Sorting

2011-09-02 22:40 211 查看
题目:DNA Sorting

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since
D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence
``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by
m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT


Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


主要思路:

1. 实质上是一个排序问题;

2. 数组中字符串的大小由 Mesure 函数决定

3. 这里使用了最简单的选择排序,通过 TC 测试~


源代码:

#include <iostream>
#include <string>
using namespace std;

int Measure(string s, int size)
{
int result = 0;
for(int i = 0; i < size; i++)
{
for(int j = i + 1; j < size; j++)
{
if(s[i] > s[j])
{
result++;
}
}
}
return result;
}

bool Compare(string s1, string s2, int size)
{
int ms1 = Measure(s1, size);
int ms2 = Measure(s2, size);
return ((ms1 > ms2) ? true : false);
}

void Swap(string& s1, string& s2, int size)
{
string tempstring = s1;
s1 = s2;
s2 = tempstring;
}

void Sort(string* slist, int m, int n)
{
for(int i = 0; i < m; i++)
{
int index = i;
for(int j = i+1; j < m; j++)
{
if (Compare(slist[index], slist[j], n))
{
index = j;
}
}
Swap(slist[i], slist[index], n);
}
}

void Display(string* sList, int m)
{
for(int i = 0; i < m; i++)
{
cout << sList[i] <<endl;
}
}

int main()
{
int m = 0;
int n = 0;
cin >> n >> m;
string* sList = new string[m];
for(int i = 0; i < m; i++)
{
cin >> sList[i];
}

Sort(sList, m, n);
Display(sList, m);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: