您的位置:首页 > 其它

HDU-1224 Free DIY Tour 最长上升子序列

2011-08-31 22:51 323 查看
  

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1135 Accepted Submission(s): 381


[align=left]Problem Description[/align]
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 andN+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

[align=left]Input[/align]
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

[align=left]Output[/align]
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

[align=left]Sample Input[/align]

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

[align=left]Sample Output[/align]

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

  该题算是最长上升子序列的一个小的综合训练,咋看题目可能觉得更像是一道搜索题(好像搜索也能过)。但是,题目中说了一个重要的信息,a city with higher number has no straight flight to a city with lower number. 这样就复杂度而言就是一个很大的下降了。 知道了之后就是写程序了,这题有点不同的是我们可以直接在那个兴趣值上进行操作,因为兴趣值本身不能够在两点之间建立某种关系,建立关系的是 map[][] 数组下标,还有就是记录路径了,每个点对应一个记录父亲的next[]数组,最后倒着输出来就可以了。
  代码如下:

#include <cstdlib>
#include <cstring>
#include <cstdio>
using namespace std;

int rec[1005], dp[1005];

int main()
{
int N;
while( scanf( "%d", &N ), N )
{
memset( dp, 0, sizeof( dp ) );
for( int i = 0; i < N; ++i )
{
scanf( "%d", &rec[i] );
dp[i] = rec[i];
}
for( int i = 0; i < N; ++i )
{
int max = 0;
for( int j = 0; j <= i; ++j )
{
if( rec[i] > rec[j] && max < dp[j] )
max = dp[j];
}
dp[i] = max + rec[i];
}
int max = -0x7fffffff;
for( int i = 0; i < N; ++i )
{
max = max > dp[i] ? max : dp[i];
}
printf( "%d\n", max );
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: