您的位置:首页 > 其它

ACM HDU 2509 Be the Winner(博弈)

2011-08-29 16:29 447 查看

Be the Winner

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 504 Accepted Submission(s): 247


[align=left]Problem Description[/align]
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

[align=left]Input[/align]
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

[align=left]Output[/align]
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

[align=left]Sample Input[/align]

2
2 2
1
3

[align=left]Sample Output[/align]

No
Yes

[align=left]Source[/align]
ECJTU 2008 Autumn Contest

[align=left]Recommend[/align]
lcy

[b]和HDU1907是一样的题目。详细解释看:[/b]

[b]/article/4679878.html[/b]

[b]代码:[/b]

#include<stdio.h>
int a[105];
int main()
{
int i,ans,n,temp;
while(scanf("%d",&n)!=EOF)
{
temp=0;//孤单堆
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(i==0)
ans=a[i];
else
ans=ans^a[i];
if(a[i]>1)  temp=1;
}
if(temp==0)
{
if(n%2==1)
printf("No\n");
else
printf("Yes\n");
continue;
}
if(ans==0)
printf("No\n");
else
printf("Yes\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: