您的位置:首页 > 其它

Function Run Fun

2011-08-25 16:19 134 查看
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11680Accepted: 6107
Description
We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:

1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:

w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print
the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source
Pacific Northwest 1999

递归加记忆化,无非就是把一些中间值加以保存下来,下次访问到该数时就无需再计算。由于递归的效率十分的慢,由于每一次都需要对计算过的数又重新的计算一遍,如果用记忆化,那么下次求该数或者比该数大的数,都无需要对此再进行计算一遍,从而缩短了时间的开销!!

#include <iostream>

#include <cstdio>

#include <cstring>

using namespace std;

int num[21][21][21];

int w(int a,int b,int c)

{

if(a<=0 ||b<=0 ||c<=0)

return 1;

if(a>20 ||b>20 ||c>20)

return num[20][20][20]=w(20,20,20);

if(num[a][b][c]!=0)//返回中间过程的值

return num[a][b][c];

if(a<b && b<c)

return num[a][b][c]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);

else return num[a][b][c]=w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);

}

int main()

{

int a,b,c;

int sum;

while(scanf("%d%d%d",&a,&b,&c)!=EOF)

{

memset(num,0,sizeof(num));

if(a==-1 && b==-1 && c==-1)

break;

sum=w(a,b,c);

printf("w(%d, %d, %d) = %d\n",a,b,c,sum);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: