您的位置:首页 > 其它

An easy problem

2011-08-16 22:59 155 查看

An easy problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2563 Accepted Submission(s): 1806


[align=left]Problem Description[/align]

In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.

[align=left]Input[/align]

The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.

[align=left]Output[/align]

For each test case, print out the multiply table.

[align=left]Sample Input[/align]

2
1
4

[align=left]Sample Output[/align]
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16

#include <stdio.h>
int main( )
{
int N, T;
scanf("%d", &T);
while(T--) {
scanf("%d", &N);
int i, j, flag = 0;
for(i = 1; i <= N; i++) {
for(j = 1; j <= N; j++) {
if (!flag)
printf("%d",i * j), flag = 1;
else
printf(" %d",i *j);
}
flag = 0;
puts("");
}
}
return 0;
}


Hint
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: