您的位置:首页 > 其它

sum it up hdu 1258

2011-08-11 20:20 351 查看

Sum It Up

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1 Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Given a specified total t and a list of n integers, find all distinct
sums using numbers from the list that add up to t. For example, if t=4,
n=6, and the list is [4,3,2,2,1,1], then there are four different sums
that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as
many times as it appears in the list, and a single number counts as a
sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test
case contains t, the total, followed by n, the number of integers in the
list, followed by n integers x1,...,xn. If n=0 it signals the end of
the input; otherwise, t will be a positive integer less than 1000, n
will be an integer between 1 and 12(inclusive), and x1,...,xn will be
positive integers less than 100. All numbers will be separated by
exactly one space. The numbers in each list appear in nonincreasing
order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the
total, and a colon. Then output each sum, one per line; if there are no
sums, output the line 'NONE'. The numbers within each sum must appear in
nonincreasing order. A number may be repeated in the sum as many times
as it was repeated in the original list. The sums themselves must be
sorted in decreasing order based on the numbers appearing in the sum. In
other words, the sums must be sorted by their first number; sums with
the same first number must be sorted by their second number; sums with
the same first two numbers must be sorted by their third number; and so
on. Within each test case, all sums must be distince; the same sum
connot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0


Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


Source

呵呵,第二次写。全新的感觉。。关键是要理解递归。。。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int A[1000];
int hash[1000];
int N, M, flag = 0;

void debug( )
{
#ifdef P
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
#endif
}

void DFS(int x, int sum, int n)
{
int i, j;
if (sum == N)
{
if (flag == 0) {
printf("Sums of %d:\n", N);
flag = 1;
}
printf("%d",hash[0]);
for (j = 1; j < n; j++)
printf("+%d", hash[j]);
puts("");
return;
}
else {
for (i = x; i < M; i++) {
if ( A[i] > N)
continue;
else
{
//puts("**");
if (sum + A[i] > N)
continue;
if (x < i && A[i] == A[i -1])
continue;
hash
= A[i];   //4 6 4 3 2 2 1 1
DFS(i + 1, sum + A[i], n + 1);
}
}
}
}

int main( )
{

int i, j;
debug( );
while (scanf("%d%d", &N, &M) , N || M)
{
flag = 0;
for (i = 0; i < M; i++)
scanf("%d",&A[i]);
memset(hash, 0, sizeof(hash));
DFS( 0, 0 , 0);
if (!flag) {
printf("Sums of %d:\n",N);
puts("NONE");
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: