您的位置:首页 > 其它

joj 1003

2011-08-07 12:35 901 查看




1003:
Channel Allocation

ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE

3s8192K3470639Standard
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere
with one another. This condition is satisfied if adjacent repeaters use different channels. Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a
program that reads in a description of a repeater network and determines the minimum number of channels required.


INPUT

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For
example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. Following the number of repeaters is a list of adjacency relationships. Each line has the form: A:BCDH which indicates that the repeaters
B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form A: The repeaters are
listed in alphabetical order. Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line
segments that cross.


OUTPUT

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form
when only one channel is required.


SAMPLE INPUT

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0


SAMPLE OUTPUT

1 channel needed.
3 channels needed.
4 channels needed.


Submit / Problem List / Status / Discuss

Problem Set with Online Judge System Version 3.12

这是一个着色的问题,已经证明在一个地图上用四种颜色就可以使相邻的图像不同颜色

#include<cstdio>

#include<string.h>

using namespace std;

int map[27][27];//储存点之间的位置关系

int dot[27];//储存每个点所用的颜色

int m;//颜色总数

bool temp;

bool ok(int n)//判断当某个点染色时是否符合条件

{

for(int i=1;i<n;i++)

if(dot[i]==dot
&&map
[i])return false;

return true;

}

void dfs(int num,int n)

{

if(num-1==n)

{

temp=true;

return;

}

for(int i=1;i<=m;i++)

{

dot[num]=i;

if(ok(num))dfs(num+1,n);

dot[num]=0;

}

}

int main()

{

int n;

char store[30];

while(scanf("%d",&n),n)

{

getchar();

memset(map,0,27*27*sizeof(int));

memset(dot,0,sizeof(dot));

for(int i=1;i<=n;i++)//输入各个点的相对位置情况

{

gets(store);

int count=2;

while(store[count]!='\0')

{

map[i][store[count]-'A'+1]=1;

++count;

}

}

temp=false;

for(m=1;m<=n;m++)

{

dfs(1,n);

if(temp)break;

}

if(m==1)printf("1 channel needed.\n");

else printf("%d channels needed.\n",m);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: