您的位置:首页 > 其它

hdu 3915 Game

2011-08-05 21:01 417 查看
Problem Description
Mr.Frost is a child who is too simple, sometimes naive, always plays some simple but interesting games with his friends. Today,he invents a new game again:

At the beginning of the game they pick N (1<=N<=100) piles of stones, Mr.Frost and his friend move the stones in turn. At each step of the game, the player chooses a pile, removes at least one stone from the pile, the first player can’t make a move, and loses.
So smart is the friends of Mr.Frost that Mr.Frost always loses. Having been a loser for too many times, he wants to play a trick. His plan is to remove some piles, and then he can find a way to make sure that he would be the winner after his friends remove
stones first.

Now, he wants to know how many ways to remove piles which are able to achieve his purpose. If it’s impossible to find any way, please print “-1”.


Input
The first line contains a single integer t (1<=t<=20), that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer N (1 <= N <= 100), representing the number of the piles.
The next n lines, each of which has a positive integer Ai(1<=Ai<=2^31 - 1) represent the number of stones in this pile.


Output
For each case, output a line contains the number of the way mod 1000007, If it’s impossible to find any way, please print “-1”.


Sample Input
2
2
1
1
3
1
2
3




Sample Output
2
2




Source
2011 Multi-University Training Contest 8 - Host by HUST



Recommend
lcy

简单的高斯消元的应用,要求的就是给定n个数中选k个数异或为0的方法数。将n个数用二进制写成n列,之后就很明显了,未知数x1--xn非1即0,表示第i个数取不取。

用高斯消元计算出有多少不确定的变元,这些变元要么是1,要么是0,所以答案即为2的变元数次方。

代码如下

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 105

int A[105][105];

inline int gauss(int r,int c)
{
    int k,col,i,j,kk;
    int an;
    for(k=col=0;k<r&&col<c;k++,col++)
    {
        kk=k;
        for(i=k+1;i<r;i++)
            if(abs(A[i][col])>abs(A[kk][col])) kk=i;
        if(kk!=k)
        {
            for(j=col;j<=c;j++)
                swap(A[k][j],A[kk][j]);
        }
        if(A[k][col]==0)
        {
            k--;
            continue ;
        }
        for(i=k+1;i<r;i++)
            if(A[i][col]!=0)
                for(j=col;j<=c;j++)
                    A[i][j]^=A[k][j];
    }
    int ans=1;
    for (i=0;i<(c-k);i++)
    {
        ans=(ans*2)%1000007;
    }
    return ans;
}

int main()
{
    int T,i,j,t,up,y,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        t=0;
        memset(A,0,sizeof(A));
        for (i=0;i<n;i++)
        {
            scanf("%d",&y);
            up=0;
            while(y!=0)
            {
                A[up++][i]=(y & 1);
                y>>=1;
            }
            t=max(t,up);
        }
        for (i=0;i<t;i++)
        {
            A[i]
=0;
        }
        printf("%d\n",gauss(t,n));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: