您的位置:首页 > 其它

sdut 1500 Message Flood

2011-08-04 19:45 507 查看
一道简单的Trie树,好长时间没写过了,手生了,wA了好几次...

Message Flood

Time Limit:1500MS Memory Limit:65536K
Total Submit:467 Accepted:93

Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0


Sample Output

3


题目大意:给n个字符串,然后又给出m个字符串,问前n个字符串有多少个没有在m个串中出现。每个字符串长度不超过10,不区分字母大小写。


数据量很大,简单模拟肯定不行,很显然要用Trie树。。


直接贴下代码:



View Code

# include<stdio.h>
# include<string.h>
# define MAX 26
struct Trie{
int num;
struct Trie *next[MAX];
};
Trie *NewTrie()
{
int i;
Trie *p= new Trie;
for(i=0;i<MAX;i++)
p->next[i]=NULL;
p->num=0;
return p;
}
void Insert(Trie *p,char s[])
{
int i,len,ans;
len=strlen(s);
Trie *temp=p;
for(i=0;i<len;i++)
{
if(s[i]>='A' && s[i]<='Z') ans=s[i]-'A';
else ans=s[i]-'a';
if(temp->next[ans]==NULL) temp->next[ans]=NewTrie();
temp=temp->next[ans];
}
temp->num=1;
}
int query(Trie *p,char s[])
{
Trie *temp=p;
int i,len,ans;
len=strlen(s);
for(i=0;i<len;i++)
{
if(s[i]>='A' && s[i]<='Z') ans=s[i]-'A';
else ans=s[i]-'a';
if(temp->next[ans]==NULL) return 0;
temp=temp->next[ans];
}
if(temp->num==1) {temp->num=0;return 1;}
return 0;
}
void Delete(Trie *p)
{
int i;
for(i=0;i<MAX;i++)
if(p->next[i]!=NULL) Delete(p->next[i]);
delete p;
p=NULL;
}
int main()
{
int i,n,m,count;
char str[12];
Trie *p;
while(scanf("%d",&n)!=EOF && n)
{
scanf("%d",&m);
p=NewTrie();
for(i=0;i<n;i++)
{
scanf("%s",str);
Insert(p,str);
}
count=0;
while(m--)
{
scanf("%s",str);
count+=query(p,str);
}
printf("%d\n",n-count);
Delete(p);
}
return 0;
}



最后一个Delete函数,主要是为了释放空间, 不过时间耗时非常大。时间:500ms , 空间消耗1W+

去掉Delete函数,时间:250ms,空间消耗:5w+


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: