您的位置:首页 > 编程语言 > Go语言

poj 1442 Black Box

2011-08-03 11:36 267 查看
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and
i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 

N Transaction i Black Box contents after transaction Answer

(elements are arranged by non-descending)

1 ADD(3)      0 3

2 GET         1 3                                    3

3 ADD(1)      1 1, 3

4 GET         2 1, 3                                 3

5 ADD(-4)     2 -4, 1, 3

6 ADD(2)      2 -4, 1, 2, 3

7 ADD(8)      2 -4, 1, 2, 3, 8

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8

9 GET         3 -1000, -4, 1, 2, 3, 8                1

10 GET        4 -1000, -4, 1, 2, 3, 8                2

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 

Let us describe the sequence of transactions by two integer arrays: 

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 

Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6


Sample Output
3
3
1
2


这个题大意是取前u(i)个数排序~然后取第i个数~(i=1,2,3……)

看似是很简单的排序题~我开始用qsort~一直是WA~

后来发现可以用大顶堆和小顶堆做~

每次将u(i)个数存入小顶堆中~

取小顶堆堆顶元素存入大顶堆中~删除堆顶元素~

将大顶堆堆顶元素存入小顶堆中删除堆定元素

~
这样大顶堆中的元素个数不变~总是最小的前i个~

话说这道题说元素的范围是-

2,000,000,000~+2,000,000,000~

我没多想就干脆用了long long~
结果一次提交侥幸AC了~960+ms~第二次提交果然就超时了~

后来改为了long~760+ms就AC了~

我算了一下~long 最大值为2^31-1,用换底公式得9.3320左右~也就是说换成十进制大概是九至十位~

我在网上看到还有用int 提交AC了的~至于为什么~我还是没弄明白~~

#include"iostream"
#include"queue"
#include"deque"
using namespace std;
int m,n;
int num;
long a[30003];
long b[30003];
int i;
priority_queue<long,deque<long>,less<long> >big;
priority_queue<long,deque<long>,greater<long> >small;
int main()
{
int count;
while(cin>>m>>n)
{
for(i=0;i<m;i++)
cin >> a[i];
for(i=0;i<n;i++)
cin >> b[i];
count=1;
num=0;
i=0;
while(count<=n)
{
for(;i<b[num];i++)
{
small.push(a[i]);
big.push(small.top());
small.pop();
small.push(big.top());
big.pop();
}
big.push(small.top());
small.pop();
cout << big.top()<< endl;
count++;
num++;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息