您的位置:首页 > 其它

HDU 1058 Humble Numbers

2011-08-02 15:55 274 查看
 

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6116    Accepted Submission(s): 2652


[align=left]Problem Description[/align]
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

 

[align=left]Input[/align]
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

[align=left]Output[/align]
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

 

[align=left]Sample Input[/align]

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

[align=left]Sample Output[/align]

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

 

[align=left]Source[/align]
University of Ulm Local Contest 1996

 

[align=left]Recommend[/align]
JGShining
 
一睇就知道系水题………………
不过我WA左11次,我反复改核心算法,都系WA,其实问题出系输出,大家有无发觉11,12,13做结尾既时候唔会分st,nd,rd,我实在唔知道呢样野


核心算法就系每次都将当前位置既数乘以四个因子,选出最小者,作为下一个最小值,其实就系维护最小值问题,自然就会捻到优先队列,防重复就用映射。
 
贴代码



43135852011-08-02 15:50:09Accepted105878MS560K840 BC++10SGetEternal{(。)(。)}!
 
#include <queue>
#include <map>
#include <iostream>
#include <functional>
using namespace std;
#define MAXI 5843

priority_queue<__int64, vector<__int64>, greater<__int64> > Q;
__int64 hn[MAXI], l;
map<__int64, bool> exi;

void init()
{
__int64 tmp;
l = 1;
Q.push(1);
while (l < MAXI)
{
tmp = Q.top();
Q.pop();
if (exi[tmp]) continue;
exi[tmp] = 1;
hn[l++] = tmp;
Q.push(tmp * 2);
Q.push(tmp * 3);
Q.push(tmp * 5);
Q.push(tmp * 7);
}
}

int main()
{
int n;

init();
while (scanf("%d", &n), n)
{
printf("The %d", n);
if (n % 10 == 1 && n % 100 != 11) printf("st ");
else if (n % 10 == 2 && n % 100 != 12) printf("nd ");
else if (n % 10 == 3 && n % 100 != 13) printf("rd ");
else printf("th ");
printf("humble number is %I64d.\n", hn
);
}

return 0;
}


无文化,真可怕

…………
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息