您的位置:首页 > 理论基础 > 数据结构算法

PKU 2352 Stars

2011-07-31 21:47 316 查看
Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18171 Accepted: 7918
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at
one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source
Ural Collegiate Programming Contest 1999

今次系可以同并查集媲美既精巧数据结构!!树状数组!

呢题好基本既树状数组应用…………维护区间和首先介绍一下树状数组三神器:

 

求最高位数位运算:

 

x += (x & (-x)); //自己推算应该明白,呢个系树状数组精巧既关键


 

Update函数负责更新:

void update(int x)
{
while (x <= MAXI)
{
tre[x] ++;       //更新区间和
x += (x & (-x)); //搵到老豆
}
}


Query负责查询:

int query(int x)
{
int sum = 0;

while (x > 0)
{
sum += tre[x];   //累加区间和
x -= (x & (-x)); //稳仔
}

return sum;
}


尼条题主要思路就系用树状数组作为一个hash表记录映射到记录高度level既记录数组。

8615413GZHU10061001062352Accepted2668K172MSC++621B2011-05-09 13:13:18
 
#include <iostream>
using namespace std;
#define MAXI 320006

int tre[MAXI], lev[MAXI];

void update(int x)
{
while (x <= MAXI)
{
tre[x] ++;
x += (x & (-x));
}
}

int query(int x)
{
int sum = 0;

while (x > 0)
{
sum += tre[x];
x -= (x & (-x));
}

return sum;
}

int main()
{
int i, n, x, y;

while (scanf("%d", &n) != EOF)
{
memset(tre, 0, sizeof tre);
memset(lev, 0, sizeof lev);
for (i = 0; i < n; i++)
{
scanf("%d%d", &x, &y);
x++;
lev[query(x)]++;
update(x);
}
for (i = 0; i < n; i++)
printf("%d\n", lev[i]);
}
return 0;
}


 

经典题目!

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息