您的位置:首页 > 编程语言 > PHP开发

PKU 2777 Count Color

2011-07-31 21:31 211 查看
Count Color

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21363 Accepted: 6218
Description
Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment
with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the
beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input
First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may
be larger than B) as an operation defined previously.
Output
Ouput results of the output operation in order, each line contains a number.
Sample Input
2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output
2
1

好基础既线段树覆盖问题,LazyTag都唔洗用,直接贴代码…………

8711966GZHU10061001062777Accepted3244K360MSC++1523B2011-05-31
23:04:17
#include <iostream>
using namespace std;
#define MAXI 100001
#define ls(x) x << 1
#define rs(x) (x << 1) + 1

struct SegTree
{
struct node
{
int l, r, c;
}t[3 * MAXI];

bool hco[33];

void inti(int x, int a, int b)
{
int mid = (a + b) >> 1;

t[x].c = 1;
t[x].l = a;
t[x].r = b;

if (a < b)
{
inti(ls(x), a, mid);
inti(rs(x), mid + 1, b);
}
}

void insert(int x, int a, int b, int c)
{
int mid = (t[x].l + t[x].r) >> 1;

if (a <= t[x].l && t[x].r <= b)
t[x].c = c;
else
{
if (t[x].c > 0)
{
t[ls(x)].c = t[rs(x)].c = t[x].c;
t[x].c = -1;
}
if (a <= mid) insert(ls(x), a, b, c);
if (b > mid) insert(rs(x), a, b, c);
}
}

void search(int x, int a, int b)
{
int mid = (t[x].l + t[x].r) >> 1;

if (t[x].c > 0) hco[t[x].c] = 1;
else
{
if (a <= mid) search(ls(x), a, b);
if (b > mid) search(rs(x), a, b);
}
}

int statistic(int a, int b)
{
int i, sum = 0;;

memset(hco, 0, sizeof hco);
search(1, a, b);
for (i = 1; i < 33; i++)
if (hco[i]) sum++;
return sum;
}

}zkl;

int main()
{
int L, T, O, a, b, c;
char o;

while (scanf("%d%d%d", &L, &T, &O) != EOF)
{
zkl.inti(1, 1, L);

while (O--)
{
getchar();
scanf("%c%d%d", &o, &a, &b);
if (a > b) swap(a, b);

if (o == 'C')
{
scanf("%d", &c);
zkl.insert(1, a, b, c);
}
if (o == 'P') printf("%d\n", zkl.statistic(a, b));
}
}

return 0;
}
其实系小水题

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息