您的位置:首页 > 大数据 > 人工智能

hdu Easier Done Than Said?

2011-07-28 15:34 239 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1039
发现自己真的不够细心。。整个写下来好多错误。。调试了半天。。。。思维啊,严谨啊

[align=left]Problem Description[/align]Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

[align=left]Input[/align]The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

[align=left]Output[/align]For each password, output whether or not it is acceptable, using the precise format shown in the example.

[align=left]Sample Input[/align]
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end


[align=left]Sample Output[/align]
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

#include <iostream>
#include <string.h>
using namespace std;
int main()
{
char pass[100],end[4]={"end"},a[6]={'a','e','i','o','u'};
while(cin>>pass)
{ int t,k1,k2,i,j,k,n,b=0;
if(strcmp(pass,end)==0)
break;
cout<<"<"<<pass<<"> is";
n=strlen(pass);
t=0;
for(i=0;i<n&&b!=-1;i++)
{

if(pass[i]!='e'&&pass[i]!='o') //因为ee oo 除外
if(pass[i]==pass[i+1]) //条件三:不能连续两个一样
b=-1;
if(b!=-1)
{
k1=0;k2=0; //条件二:
for(k=i;k<i+3&&k<n;k++) //不能连续三个是元音或者三个辅音
{ //其实除了第一次,后边的每次只是多加一个。可以优化
b=k1;
for(j=0;j<5;j++)
if(pass[k]==a[j])
{
k1++;
t=1; //条件一:含有元音
}
if(k1==b)
k2++;
}
if(k1>2||k2>2)
b=-1;
}
}

if(b==-1||t==0)
cout<<" not acceptable."<<endl;
else
cout<<" acceptable."<<endl;

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: