您的位置:首页 > 其它

hdu 1035 Robot Motion

2011-07-27 17:16 295 查看
[align=left]直接模拟走就行了。。。但是搞了好长。。。只考虑i=0,j=0.。没有考虑从那半边出去。。思考不严谨啊[/align][align=left] [/align][align=left] [/align][align=left]Problem Description[/align]

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

[align=left]Input[/align]There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

[align=left]Output[/align]For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

[align=left]Sample Input[/align]
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0

[align=left]Sample Output[/align]
10 step(s) to exit
3 step(s) before a loop of 8 step(s) [code]
#include <iostream>
using namespace std;
char b;
char a[13][13];
int c[13][13];
int main()
{
int x,y,k,i,j,t,m;
while(cin>>x>>y,x||y)
{
cin>>k; for(i=0;i<=x+1;i++)
for(j=0;j<=y+1;j++)
{
c[i][j]=0;
if(i==0||j==0||i==x+1||j==y+1) //边界初始化为1
a[i][j]=0;
else
cin>>a[i][j];
}
i=1;
j=k;
b=a[i][j];
m=0,t=1;
while(1)
{
if(c[i][j]!=t) //判断是否是已经走过的
{
c[i][j]=1; //走过的进行标记
if(b=='N')
i--;
else if(b=='S')
i++;
else if(b=='W')
j--;
else
j++;
b=a[i][j]; //将下一个的方向传给b
}
else //如果是走到已经走过的,说明有循环,
{ //那么从头开始走,走到有循环处
a[i][j]=0;
i=1;
j=k;
b=a[i][j];
t=m;
m=-1;
}
m++;
if(b==0) //结束条件
break;
}
if(t==1)
cout<<m<<" step(s) to exit"<<endl;
else
cout<<m<<" step(s) before a loop of "<<t-m<<" step(s)"<<endl;
}
} ...这种找到有循环的时候直接就结束了。。开始想复杂了。#include <iostream>using namespace std;char b; char a[13][13]; int c[13][13];int main(){ int x,y,k,i,j,t,m; while(cin>>x>>y,x||y) { cin>>k; for(i=0;i<=x+1;i++) for(j=0;j<=y+1;j++) { c[i][j]=0; if(i==0||j==0||i==x+1||j==y+1) //边界初始化为1 a[i][j]=0; else cin>>a[i][j]; } i=1; j=k; b=a[i][j]; m=0,t=1; while(1) { c[i][j]=++m; //走过的进行标记 a[i][j]='o'; if(b=='N') i--; else if(b=='S') i++; else if(b=='W') j--; else j++; b=a[i][j]; //将下一个的方向传给b if(b==0||a[i][j]=='o') //结束条件 break; } if(a[i][j]!='o') cout<<m<<" step(s) to exit"<<endl; else cout<<c[i][j]-1<<" step(s) before a loop of "<<m+1-c[i][j]<<" step(s)"<<endl; }[/code]http://acm.hdu.edu.cn/showproblem.php?pid=1035
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: