您的位置:首页 > 其它

poj 3356 AGTC

2011-07-24 10:35 239 查看
DescriptionLet x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:
Deletion: a letter in x is missing in y at a corresponding position.
Insertion: a letter in y is missing in x at a corresponding position.
Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.
Illustration
A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C
Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinctThis tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like
A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C
and 4 moves would be required (3 changes and 1 deletion).
In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.
Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.
Write a program that would minimize the number of possible operations to transform any string x into a string y.
InputThe input consists of the strings x and y prefixed by their respective lengths, which are within 1000.
OutputAn integer representing the minimum number of possible operations to transform any string x into a string y.
Sample Input
10 AGTCTGACGC
11 AGTAAGTAGGC
Sample Output
4
SourceManila 2006

又解决一道当年遗留下来的题……
这题类似最长公共子串,只是稍微变了一下罢了……注意初始化……
直接上代码,没什么好说的了……多校第一场貌似也有一道这种变题,这两天解决去……
#include <stdio.h>
#include <algorithm>
using namespace std;

#define INF 999999999

char str1[1005];
char str2[1005];
int dp[1005][1005];

int main()
{
    int i,j,n,m,x,y;
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s",str1);
        scanf("%d",&m);
        scanf("%s",str2);
        for (i=0;i<=n;i++)
        {
            dp[i][0]=i;
        }
        for (i=0;i<=m;i++)
        {
            dp[0][i]=i;
        }
        dp[0][0]=0;
        for (i=1;i<=n;i++)
        {
            for (j=1;j<=m;j++)
            {
                x=i-1;
                y=j-1;
                if (str1[x]==str2[y]) dp[i][j]=min(dp[i-1][j-1],min(dp[i-1][j],dp[i][j-1])+1);
                else dp[i][j]=min(min(dp[i-1][j],dp[i][j-1]),dp[i-1][j-1])+1;
            }
        }
        printf("%d\n",dp
[m]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: