您的位置:首页 > 其它

1500_Message Flood

2011-07-23 14:51 295 查看
Message Flood

Time Limit:1500MS Memory Limit:65536K
Total Submit:284 Accepted:40

Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Sample Output

二分法+快排,试着用哈希表做了,但做了半天没能解决

View Code

#include <stdio.h>
#include <string.h>
#include <malloc.h>
typedef struct node
{
int flag;
struct node *next[26];
}Node;
int tmp;
Node * NewNode()
{
int i;
Node * p = (Node *)malloc(sizeof(Node));
p->flag = 0;
for(i = 0; i < 26; i++)
p->next[i] = 0;
return p;
}
void insert(Node * root, char s[])
{
int n = strlen(s);
int i;
Node * p;
p = root;
for(i = 0; i < n; i++)
{
if(p->next[s[i] - 'a'] == NULL)
p->next[s[i] - 'a'] = NewNode();
p = p->next[s[i] - 'a'];
}
p->flag = 1;
}
void search(Node * root, char s[])
{
int len = strlen(s);
int i;
Node *p;
p = root;
for(i = 0; i < len; i++)
{
if(p->next[s[i] - 'a'] != NULL)
p = p->next[s[i] - 'a'];
}
if(p->flag)
{
p->flag = 0;
tmp--;
}
}
void del(Node * p)
{
int i;
if(p)
{
for(i = 0; i < 26; i++)
if(p->next[i])
del(p->next[i]);
}
free(p);
p = NULL;
}
void change(char s[])
{
int len, i;
len = strlen(s);
for(i = 0; i  < len; i++)
if(s[i] >= 'A' && s[i] <= 'Z')
s[i] += 32;
}
int main()
{
int n, m;
char s[11];
Node *root;
while(scanf("%d", &n),n)
{
tmp = n;
scanf("%d", &m);
root = NewNode();
while(n--)
{
scanf("%s", s);
change(s);
insert(root, s);
}
while(m--)
{
scanf("%s", s);
change(s);
search(root, s);
}
printf("%d\n", tmp);
//del(root);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: