您的位置:首页 > 编程语言 > PHP开发

最大流(增广路-EK)poj1273

2011-07-12 21:44 344 查看
Drainage Ditches

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 31138Accepted: 11423
Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a
set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate
water flows into that ditch. 

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N
is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1
<= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input

5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10 

Sample Output

50

这是本人第一题网络流,很基础,但此题应该注意数据是多case,还有就是会有重边,重边应该在该边上加容量就行了。下面是我的代码

#include<cstdio>
#include<queue>
#include<iostream>
#define N 205
#define inf 0x7ffffff
using namespace std;
int gp

,flow

,p
,a
,n;
int EK(int s,int t)
{
queue<int>q;
memset(flow,0,sizeof(flow));
int ans=0;
while(1)
{
memset(a,0,sizeof(a));
memset(p,-1,sizeof(p));
a[s]=inf;
p[s]=0;
q.push(s);
while(!q.empty())
{
int u=q.front();
q.pop();
for(int i=0;i<=n;i++)
{
if(a[i]==0&&gp[u][i]-flow[u][i]>0&&p[i]==-1)
{
a[i]=a[u]<gp[u][i]-flow[u][i]?a[u]:gp[u][i]-flow[u][i];
p[i]=u;
q.push(i);
}
}
}
if(a[t]==0)
break;
for(int u=t;u!=s;u=p[u])
{
flow[p[u]][u]+=a[t];
flow[u][p[u]]-=a[t];
}
ans+=a[t];
}
return ans;
}
int main()
{
int c,x,y,w;
while(scanf("%d%d",&c,&n)!=EOF)
{
memset(gp,0,sizeof(gp));
for(int i=0;i<c;i++)
{
scanf("%d%d%d",&x,&y,&w);
gp[x][y]+=w;
}
printf("%d\n",EK(1,n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息