您的位置:首页 > 其它

hdu 1198/zoj 2412

2011-07-11 20:49 375 查看

Farm Irrigation

[align=left]Problem Description[/align]Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.



Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like



Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?
Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
[align=left]Input[/align]There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
[align=left]Output[/align]For each test case, output in one line the least number of wellsprings needed.
[align=left]Sample Input[/align]
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

[align=left]Sample Output[/align]
2
3 题目的意思是:给你一块地,这块地被分割成许多小正方形,每个正方形中都安装了水管,不同的正方形中可能安装的水管不同,一共有11种水管,分别用字母A~K表示, 某些正方形地块的中心有水源,问你至少需要多少个水管,以保证整个正方形农田都能被灌溉。 解题思路:将每个正方形土地上的水管按照顺时针方向标记,有水管记为1,没有记为0,好在土地上最多只有四个方向有水管,然后对每一个水管进行深度搜索,如果水管能 够接通,则继续深搜并将前一个标记,直到某块地的四个方向都不能和没有标记的外界地块相连为止。本题实质上是利用深度搜索寻找连续的土地块,刚开始看题的时候感觉很 难,结果一次就A了,感觉还是挺简单的! 下面是我的代码: #include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int m,n;
//将正方形地块上的水管按照顺时针方向标记,有为1,没有为0
int a[12][4]={{1,0,0,1},{1,1,0,0},{0,0,1,1},{0,1,1,0},{1,0,1,0},{0,1,0,1},
{1,1,0,1},{1,0,1,1},{0,1,1,1},{1,1,1,0},{1,1,1,1}};
int map[55][55];
bool flag[55][55];

//深搜
void dfs(int x,int y)
{
flag[x][y]=1;
for(int z=0;z<4;z++)
{
if(z==0&&a[map[x][y]][z]&&x>=1&&a[map[x-1][y]][2]&&!flag[x-1][y]) dfs(x-1,y);
else if(z==1&&a[map[x][y]][z]&&y+1<n&&a[map[x][y+1]][3]&&!flag[x][y+1]) dfs(x,y+1);
else if(z==2&&a[map[x][y]][z]&&x+1<m&&a[map[x+1][y]][0]&&!flag[x+1][y]) dfs(x+1,y);
else if(z==3&&a[map[x][y]][z]&&y>=1&&a[map[x][y-1]][1]&&!flag[x][y-1]) dfs(x,y-1);
}
}
int main()
{
char ch[55];
while(scanf("%d%d",&m,&n)!=EOF)
{
if(m==-1&&n==-1) break;
memset(map,0,sizeof(map));
for(int i=0;i<m;i++)
{
scanf("%s",ch);
for(int j=0;j<n;j++)
map[i][j]=ch[j]-'A';
}
memset(flag,0,sizeof(flag));
int count=0;
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(flag[i][j]) continue;
dfs(i,j);
count++;
}
}
cout<<count<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: