您的位置:首页 > 大数据 > 人工智能

poj1273 Drainage Ditches

2011-05-24 23:31 218 查看
                   Drainage Ditches

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30208 Accepted: 11051
Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output
50

/*
标准的最大流题目,直接敲模版就可以解决,没有任何变种,不过要注意的是
记录最大容量得写成c[a1][b1]+=c1;可能题目存在平行的通道
*/
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int p[300];
int n,m;
int c[300][300],flow[300][300];
int a[300];
int bfs(int s,int t)
{
queue<int> q;
int f=0;
while(1)
{
memset(a,0,sizeof(a));
a[s]=INT_MAX;
q.push(s);
while(!q.empty())
{
int u=q.front();q.pop();
for(int v=1;v<=m;v++)
if(!a[v]&&c[u][v]>flow[u][v])
{
p[v]=u;
q.push(v);
a[v]=min(a[u],c[u][v]-flow[u][v]);
}
}
if(a[t]==0) break;
for(int u=t;u!=s;u=p[u])
{
flow[p[u]][u]+=a[t];
flow[u][p[u]]-=a[t];
}
f+=a[t];
}
return f;
}

int main()
{
int a1,b1,c1;
while(cin>>n>>m)
{
memset(c,0,sizeof(c));
memset(flow,0,sizeof(flow));
for(int i=0;i<n;i++)
{
scanf("%d%d%d",&a1,&b1,&c1);
c[a1][b1]+=c1;
}
printf("%d/n",bfs(1,m));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  each output integer forms input c