您的位置:首页 > 其它

poj 2411(插头DP 简单题)

2011-05-17 15:24 585 查看
Mondriaan's DreamTime Limit: 3000MS Memory Limit: 65536K

Total Submissions: 5930 Accepted: 3414

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt
of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2

1 3

1 4

2 2

2 3

2 4

2 11

4 11

0 0

Sample Output

1

0

1

2

3

5

144

51205

Source

Ulm Local 2000

分析:再贴一个简单的插头DP。。。

代码:

#include<cstdio>
#include<cstring>
using namespace std;
long long f[2][1<<11];
int i,j,s,p=0,c=1,n,m;
int main()
{
    while (scanf("%d%d",&n,&m),n!=0)
    {
        if (n*m%2){puts("0");continue;}
        memset(f[c],0,sizeof(f[c]));
        f[c][0]=1;
        for (i=0; i<n; ++i)
            for (j=0; j<m; ++j)
            {
                p=!p,c=!c;
                memset(f[c],0,sizeof(f[c]));
                for (s=0; s<1<<m; ++s)
                    if (f[p][s])
                    {
                        f[c][s^1<<j]+=f[p][s];
                        if(j>0&&(s&1<<j-1)&&(!(s&1<<j)))f[c][s^1<<j-1]+=f[p][s];
                    }
            }
        printf("%lld/n",f[c][0]);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: