您的位置:首页 > 其它

hdu3336 Count the string

2011-04-05 22:29 323 查看

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1147 Accepted Submission(s): 494



Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.


Input
The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.


Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.


Sample Input

1
4
abab




Sample Output

6








#include<stdio.h>
const int mod=10007;
char s[222222];
int next[222222];
void getnext(int x) {
   int i=0,j=-1;
   next[0]=-1;
   while(i<x) {
    if(j==-1||s[i]==s[j]) {
        i++;j++;
        next[i]=j;
    }
     else j=next[j];
   }
}
int main()
{
    int t,i,x;
    scanf("%d",&t);
    while(t--) {
     scanf("%d%s",&x,s);
     getnext(x);
     int ans=x;
     for(i=0;i<=x;i++)
      //关键在这里,next的值就是和前缀匹配的个数,
       if(next[i]+1!=next[i+1])
         ans=(ans+next[i])%mod;
        printf("%d/n",ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: