您的位置:首页 > 其它

POJ 3264解题报告

2011-04-04 09:24 302 查看

Balanced Lineup

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 16578Accepted: 7674
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output
6
3
0



题意:给定一个序列,每个元素有一个值,现在输入若干区间,问在该区间内的最大值和最小值差多少.....



思路:



初学线段树第一题.....



建立线段树,并加入max和min表示当前区间内的最大最小值...





#include<iostream>
using namespace std;

struct T
{
	int left,right,max,min;
}tree[150000];

int m,s;

void creat(int v,int left,int right)
{
	int mid=(left+right)/2;
	if(left==right)
	{
		tree[v].left=tree[v].right=left;
		tree[v].max=-1;
		tree[v].min=10000000;
		return;
	}
	else
	{
		tree[v].left=left;	tree[v].right=right;
		tree[v].max=-1;
		tree[v].min=10000000;
	}
	creat((v+1)*2-1,left,mid);
	creat((v+1)*2,mid+1,right);
}

void insert(int v,int left,int right,int value)
{
	int mid=(tree[v].left+tree[v].right)/2;

	if(tree[v].max<value)
		tree[v].max=value;
	if(tree[v].min>value)
		tree[v].min=value;

	if(left==tree[v].left&&right==tree[v].right)
		return ;
	else if(mid>=right)
		insert((v+1)*2-1,left,right,value);
	else if(mid<left)
		insert((v+1)*2,left,right,value);
	else 
	{
		insert((v+1)*2-1,left,mid,value);
		insert((v+1)*2,mid+1,right,value);
	}
}

void getmax(int v,int left,int right)
{
	int mid=(tree[v].left+tree[v].right)/2;
	if(left==tree[v].left&&right==tree[v].right)
	{
		if(tree[v].min<s)
			s=tree[v].min;
		if(tree[v].max>m)
			m=tree[v].max;
		return;
	}
	else if(mid>=right)
		getmax((v+1)*2-1,left,right);
	else if(mid<left)
		getmax((v+1)*2,left,right);
	else
	{		
		getmax((v+1)*2-1,left,mid);
		getmax((v+1)*2,mid+1,right);
	}
}

int main()
{
	int n,q,i,j,a,b;
	while(cin>>n>>q)
	{
		creat(0,1,n);
		for(i=1;i<=n;i++)
		{	
			cin>>j;
			insert(0,i,i,j);
		}
		for(i=0;i<q;i++)
		{
			scanf("%d%d",&a,&b);
			m=-1;	s=10000000;
			getmax(0,a,b);
			printf("%d/n",m-s);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: