您的位置:首页 > 其它

boj 1339 简单题 用递归找到最大素数因子即可

2011-03-22 17:52 169 查看
地址:http://acm.scs.bupt.cn/onlinejudge/showproblem.php?problem_id=1339

Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38

Source
jyc

#include<iostream>
using namespace std;
int ifprime(int x)
{
int max,i=2;
while(i*i<=x) //i的平方如果大于x,则i以后的因子都曾经在前面出现过
{
if(x%i==0)
{
max=ifprime(x/i); //递归判断
return max;
}
i++;
}

return x;

}
int main()
{
int i,j,n,max,sign=1;
int a[5001],b[5001];
while(cin>>n)
{
max=1;
for(i=0;i<n;i++)
{
cin>>a[i];
j=ifprime(a[i]);
b[i]=j;
}
for(i=0;i<n;i++)
{
if(max<b[i])
{
max=b[i];
sign=a[i];
}
}
cout<<sign<<endl;
}

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: