您的位置:首页 > 大数据 > 人工智能

HDOJ 1023 Train Problem II

2011-03-07 21:48 281 查看

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1840    Accepted Submission(s): 1080


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 
 

Sample Input

1
2
3
10

 
 

Sample Output

1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.

 
 

 

#include <stdio.h>
#include <string.h>
#define MAXLEN 101
#define MAXCASE 101
int catalan[MAXCASE][MAXLEN];
int temp[MAXLEN];
int main(void)
{
int i, j;
int mode = 0, res = 0, n = 0;
memset(catalan, 0, sizeof(catalan));
catalan[1][0] = 1;
for(i = 2; i < MAXCASE; i++)
{
mode = 4 * i - 2;
for(j = 0; j < MAXLEN; j++)
{
catalan[i][j] = catalan[i-1][j] * mode;
if(catalan
[j] >= 10)
{
catalan[i][j+1] += catalan[i][j] / 10;
catalan[i][j] %= 10;
}
}
memset(temp, 0, sizeof(temp));
mode = i + 1;
res = 0;
for(j = MAXLEN-1; j >= 0; j--)
{
temp[j] = (res * 10 + catalan[i][j]) / mode;
res = (res * 10 + catalan[i][j]) % mode;
}
for(j = 0; j < MAXLEN; j++)
{
catalan[i][j] = temp[j];
}
}
while(scanf("%d", &n) == 1)
{
j = MAXLEN - 1;
while(catalan
[j] == 0)
{
j--;
}
printf("%d", catalan
[j]);
while(j--)
{
printf("%d", catalan
[j]);
}
printf("/n");
}
return 0;
}
 

 

方法:卡特兰公式 

技巧:大数的乘法和除法,用数组表示大数的每一位,且大数的每一位从地位到高位放对应数组的0-MAXLEN-1,这样,作乘法是直接从0             开始循环数组,作除法是需要从MAXLEN-1开始向0下标循环数组

 

感谢http://www.wutianqi.com/?p=1281的作者的提示

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  input output each