您的位置:首页 > 编程语言 > PHP开发

hdu 1162Eddy's picture Prime算法求最小生成树

2011-03-05 18:19 555 查看

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2153    Accepted Submission(s): 1023


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

 
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

 
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

 
 

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

 
 

Sample Output

3.41典型的Prime算法求最小生成树,只要将数据处理一下就好,注意数据类型是double!!!!
#include<stdio.h>
#include<string.h>
#include<math.h>
#define maxdis 999999
double map[105][105];
double point[105][2];
int s[105];
double lowest[105],closest[105];
double dis(int i,int j)
{
double d=sqrt((point[i][1]-point[j][1])*(point[i][1]-point[j][1])+
(point[i][0]-point[j][0])*(point[i][0]-point[j][0]));
return d;
}
void calcu(int n)
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
map[i][j]=map[j][i]=dis(i,j);
}
}
void process(int n)
{
memset(s,0,sizeof(s));
for(int i=1;i<=n;i++)
{ lowest[i]=map[i][1];
closest[i]=1;
}
s[1]=1;
double sum=0;
for(int i=1;i<n;i++)
{
int u;
int min=maxdis;
for(int j=1;j<=n;j++)
if(!s[j]&&lowest[j]<min){min=lowest[j];u=j;}
s[u]=1;
sum+=lowest[u];
for(int k=1;k<=n;k++)
if(!s[k]&&lowest[k]>map[k][u]) {lowest[k]=map[k][u];closest[k]=u;}
}
printf("%.2lf/n",sum);
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++)
scanf("%lf%lf",&point[i][0],&point[i][1]);
calcu(n);
process(n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息