您的位置:首页 > 其它

poj 1017 Packets

2011-02-27 10:52 218 查看
Packets

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28810Accepted: 9481
Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.
Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.
Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1



#include<iostream>
#include<cstdio>
using namespace std;
int a[7];
int u[4]={0,5,3,1};//针对a[3]和left2
int left2,left1;
int main()
{
while(1)
{
int sum=0,cnt=0;
for(int i=1;i<=6;i++) {scanf("%d",&a[i]);sum+=a[i];}
if(sum==0) break;
cnt=a[6]+a[5]+a[4]+(3+a[3])/4;//进1法
left2=a[4]*5+u[a[3]%4];
if(a[2]>left2) cnt+=(a[2]-left2+8)/9;//进1法
left1=cnt*36-a[6]*36-a[5]*25-a[4]*16-a[3]*9-a[2]*4;
if(a[1]>left1) cnt+=(a[1]-left1+35)/36;//进1法
printf("%d/n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: