您的位置:首页 > 其它

pku 1026 Cipher 置换群

2011-02-22 11:09 267 查看
Cipher

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 13732Accepted: 3470
Description
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
Output
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
Sample Input
10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output
BolHeol  b
C RCE

题意:   给你长度n的一组序列a[i]  然后k操作次数 再给你一组字符串   字符串长度不足n的后面补零
操作:把字符在i位置的放到a[i]上   如此操作k次
方法:   直接模拟肯定TLE
    求字符串整体周期T k=k%T  k还是很大 超时
求每个字符串的周期 T[i]   然后 k=k%T[i]

[code]#include<stdio.h>
#include<string.h>
int main()
{
int i,j,k;
int n,len;
char s1[202],s2[202],c;
int a[202],b[202];
int temp,t;
while(scanf("%d",&n)!=EOF && n)
{
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;i<=n;i++)
{
t=i;
b[i]=1;
while(a[t]!=i)
{
t=a[t];
b[i]++;
}
}
scanf("%d",&k);
while(k!=0)
{
scanf("%c",&c);
gets(s1);
len=strlen(s1);
if(len<n)
{
for(i=len;i<n;i++)
{
s1[i]=' ';
}
s1
='/0';
}
for(i=0;i<n;i++)
{
temp=k%b[i+1];
t=i+1;
while(temp--)
t=a[t];
s2[t-1]=s1[i];
}
s2
='/0';
puts(s2);

scanf("%d",&k);
}
printf("/n");
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: