您的位置:首页 > 其它

POJ1013解题报告 暴力搜索

2011-02-09 17:15 405 查看
Counterfeit Dollar

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 27834Accepted: 8700
Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.
Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.
Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.
Sample Input
1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even

Sample Output
K is the counterfeit coin and it is light.

题意:A~L个球,有一个球和其他球重量不一样,现用一天平对这些球称三次,给定每次称量的结果,输出是那个球重量异常,并判断它

是重了还是轻了。

思路:暴力搜索。。。(这题代码写的有点挫)

#include<iostream>
using namespace std;
int main()
{
	char re[3][20],in[3][2][40],o[2][10]={"heavy","light"};
	int n,i,j,z,k,flag[3];	char w;
	cin>>n;
	while(n--)
	{
		for(i=0;i<3;i++)
		{
			for(j=0;j<2;j++)
				cin>>in[i][j];
			cin>>re[i];
		}
		for(w='A';w<='L';w++)
			for(z=0;z<2;z++)
			{
				for(i=0;i<3;i++)
				{
					if(!strcmp(re[i],"even"))
					{
						for(j=0;j<2;j++)
							for(k=0;k<strlen(in[i][j]);k++)
								if(in[i][j][k]==w)
									goto a;
a:
						if(j==2)
							flag[i]=1;
						else
							flag[i]=0;
					}
					else if(!strcmp(re[i],"up"))
					{
						for(j=0;j<strlen(in[i][z]);j++)
							if(in[i][z][j]==w)
								break;
						if(j==strlen(in[i][z]))
							flag[i]=0;
						else
							flag[i]=1;
					}
					else if(!strcmp(re[i],"down"))
					{
						if(z)
						{
							for(j=0;j<strlen(in[i][z]);j++)
								if(in[i][0][j]==w)
									break;
						}
						else
						{
							for(j=0;j<strlen(in[i][z]);j++)
								if(in[i][1][j]==w)
									break;
						}
						if(j==strlen(in[i][z]))
							flag[i]=0;
						else
							flag[i]=1;
					}
				}
				if(flag[0]&&flag[1]&&flag[2])
					goto end;
			}
end:
		cout<<w<<" is the counterfeit coin and it is "<<o[z]<<'.'<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: