您的位置:首页 > 产品设计 > UI/UE

1005:Number Sequence

2011-02-06 21:04 183 查看
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5代码:#include<cstdio>
const int max=52;
int f[max];int  main()
{
int a,b,n;
scanf("%d%d%d",&a,&b,&n);
a%=7;
b%=7;
while(a||b||n)
{
f[1]=1,f[2]=1;
for(int i=3;i<max;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i-1]==f[3]&&f[i]==f[4]&&i>4)
break;
}  int t=i-4;
if(n<4)
printf("%d/n",f
);
else
printf("%d/n",f[(n-4)%t+4]); /* n=(n-2)%(i-4);
printf("%d/n",f[2+n]);*/
scanf("%d%d%d",&a,&b,&n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: