您的位置:首页 > 其它

HDU 1020

2011-02-05 22:50 162 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9953 Accepted Submission(s): 4083



Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input
The
first line contains an integer N (1 <= N <= 100) which indicates
the number of test cases. The next N lines contain N strings. Each
string consists of only 'A' - 'Z' and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input

2

ABC

ABBCCC


Sample Output

ABC

A2B3C


Author
ZHANG Zheng

Recommend
JGShining

一水题啊。

有个问题,为什么用gets()会WA。。。GCC 我GOOGLE 去

#include"stdio.h"
#include"string.h"
char str[10000];
void print(){
scanf("%s",str);
int i = 0,len = strlen(str),k;
char c ;
while(i < len){
c = str[i];
k = i;
while(str[++i] == c){
}
if(i - k > 1)
printf("%d%c",i - k,c);
else
printf("%c",c);
}
printf("/n");
}
int main(){
int nCases;
scanf("%d",&nCases);
while(nCases--){
print(str);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: