您的位置:首页 > 其它

zoj 1312解题报告

2011-02-01 12:33 218 查看
Prime Cuts

Time Limit: 1 Second Memory Limit: 32768 KB

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.


Input


Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.

Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.

Sample Input

21 2
18 2
18 18
100 7


Sample Output


21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67

这道题就是先将素数表打出来,然后就是通过简单的计算就可以得出来结果了。

但是,poj1595和这道题一样,我的代码在zoj上可以通过,但是在poj上总是RUNTIME ERROR,让我十分纠结,不知道为什么。。

下面是在zoj上通过的代码。

代码:

语言:c++

#include<iostream>
using namespace std;
int main()
{
int prime[2000],num,boo[2000];
for(int i=2;i<=2000;++i)
boo[i]=0;
for(int i=2;i<=2000;++i)
for(int k=i*2;k<=2000;k+=i)
boo[k]=1;
num=1;
prime[0]=1;
for(int i=2;i<=2000;++i)
if(boo[i]==0)
prime[num++]=i;
int n,c;
while(cin>>n>>c)
{
cout<<n<<' '<<c<<": ";
int count=0,middle;
while(prime[count]<=n)
++count;
if(count%2==1&&(c*2-1)<=count)
{
c=c*2-1;
middle=count/2;
for(int i=(middle-c/2);i<=(middle+c/2);++i)
{
cout<<prime[i];
if(i!=(middle+c/2))
cout<<'#';
}
cout<<endl<<endl;
}
else if(count%2==0&&(c*2)<=count)
{
c*=2;
middle=count/2;
for(int i=(middle-c/2);i<=(middle+c/2-1);++i)
{
cout<<prime[i];
if(i!=(middle+c/2-1))
cout<<'#';
}
cout<<endl<<endl;
}
else if(count%2==0&&(c*2)>count)
{
for(int i=0;i<count;++i)
{
cout<<prime[i];
if(i!=count)
cout<<'#';
}
cout<<endl<<endl;
}
else if(count%2==1&&(c*2-1)>count)
{
for(int i=0;i<count;++i)
{
cout<<prime[i];
if(i!=count)
cout<<'#';
}
cout<<endl<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: