您的位置:首页 > 编程语言 > PHP开发

POJ 3095 Linear Pachinko 字符串模拟

2011-01-12 20:40 295 查看
http://poj.org/problem?id=3095

简单字符串模拟

Linear Pachinko

 

Time Limit: 1000MSMemory Limit: 65536K

Description

This problem is inspired by Pachinko, a popular game in Japan. A traditional Pachinko machine is a cross between a vertical pinball machine and a slot machine. The player launches small steel balls to the top of the machine using a plunger as in pinball. A ball drops through a maze of pins that deflect the ball, and eventually the ball either exits at a hole in the bottom and is lost, or lands in one of many gates scattered throughout the machine which reward the player with more balls in varying amounts. Players who collect enough balls can trade them in for prizes.

For the purposes of this problem, a linear Pachinko machine is a sequence of one or more of the following: holes ("."), floor tiles ("_"), walls ("|"), and mountains ("//"). A wall or mountain will never be adjacent to another wall or mountain. To play the game, a ball is dropped at random over some character within a machine. A ball dropped into a hole falls through. A ball dropped onto a floor tile stops immediately. A ball dropped onto the left side of a mountain rolls to the left across any number of consecutive floor tiles until it falls into a hole, falls off the left end of the machine, or stops by hitting a wall or mountain. A ball dropped onto the right side of a mountain behaves similarly. A ball dropped onto a wall behaves as if it were dropped onto the left or right side of a mountain, with a 50% chance for each. If a ball is dropped at random over the machine, with all starting positions being equally likely, what is the probability that the ball will fall either through a hole or off an end?

For example, consider the following machine, where the numbers just indicate character positions and are not part of the machine itself:

123456789
//.|__//.
The probabilities that a ball will fall through a hole or off the end of the machine are as follows, by position: 1=100%, 2=100%, 3=100%, 4=50%, 5=0%, 6=0%, 7=0%, 8=100%, 9=100%. The combined probability for the whole machine is just the average, which is approximately 61.111%.

Input

The input consists of one or more linear Pachinko machines, each 1–79 characters long and on a line by itself, followed by a line containing only "#" that signals the end of the input.

Output

For each machine, compute as accurately as possible the probability that a ball will fall through a hole or off the end when dropped at random, then output a single line containing that percentage truncated to an integer by dropping any fractional part.

Sample Input
//.|__//.
_._//_|.__//.//_
...
___
.//.
_//_
_|.|_|.|_|.|_
____|_____
#

Sample Output
61
53
100
0
100
50
53
10

/* Author : yan
* Question : POJ 3095 Linear Pachinko
* Data && Time : Wednesday, January 12 2011 07:49 PM
* Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
#define bool _Bool
#define false 0
#define true 1
char value[85];
int len;

bool rightmove(int index)
{
int i;
for(i=index+1;i<len;i++)
{
if(value[i]=='/' || value[i]=='|') return false;
if(value[i]=='.') return true;
}
return true;
}
bool leftmove(int index)
{
int i;
for(i=index-1;i>=0;i--)
{
if(value[i]=='//' || value[i]=='|') return false;
if(value[i]=='.') return true;
}
return true;
}
int main()
{
//freopen("input","r",stdin);
int ans,i;
float tmp;
for(;;)
{
gets(value);
ans=0;
tmp=0.0;
if(value[0]=='#') break;
len=strlen(value);
for(i=0;i<len;i++)
{
if( (i==0 && value[i]=='/') || (i==len-1 && value[i]=='//') ) ans+=100;
else if(value[i]=='_') ans+=0;
else if(value[i]=='.') ans+=100;
else if(value[i]=='|')
{
//考虑墙的左面
if(i==0) ans+=50;
else if( leftmove(i) ) ans+=50;
//考虑墙的右面
if(i==len-1) ans+=50;
else if( rightmove(i) ) ans+=50;
}
else if(value[i]=='/')
{
if( leftmove(i) ) ans+=100;

}
else if(value[i]=='//')
{
if( rightmove(i) ) ans+=100;
}
//printf("%d/n",ans);
}
printf("%d/n",ans/len);
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息