您的位置:首页 > 编程语言 > PHP开发

POJ 3032 简单队列模拟

2011-01-06 13:20 441 查看
http://poj.org/problem?id=3032

提交的时候正赶上系统故障,全是Runtime Error!!!

一看Online Status,原来全是RT,POJ出故障了!!!!

 

 

Card Trick

Time Limit: 1000MS Memory Limit: 65536K
Description



The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.

Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.

Three cards are moved one at a time…

This goes on until the nth and last card turns out to be the n of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.

Output

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

Sample Input
2
4
5

Sample Output
2 1 4 3
3 1 4 5 2

/* Author : yan
* Question : POJ 3032 Card Trick
* Data && Time : Wednesday, January 05 2011 10:50 PM
*/
#include<stdio.h>
typedef struct _node
{
int value;
int pos;
};
struct _node qu[150];
struct _node stack[14];
int cnt_stack;

int head,rear;

int enqueue(struct _node node)
{
qu[rear++]=node;
return rear;
}
struct _node dequeue()
{
return qu[head++];
}
int cmp(const void *a,const void *b)
{
return (*(struct _node *)a).pos - (*(struct _node *)b).pos;
}
int main()
{
//freopen("input","r",stdin);
int n;
int i,j;
int test;
struct _node cache;
scanf("%d",&test);
while(test--)
{
scanf("%d",&n);
cnt_stack=0;
head=rear=0;
for(i=0;i<n;i++)
{
struct _node node;
node.pos=i;
enqueue(node);
}
for(i=1;i<=n;i++)
{
for(j=0;j<i;j++)
{
cache=dequeue();
enqueue(cache);
}
cache=dequeue();
cache.value=i;
stack[cnt_stack++]=cache;
}

qsort(stack,cnt_stack,sizeof(stack[0]),cmp);
for(i=0;i<cnt_stack;i++)
{
printf("%d ",stack[i].value);
}
printf("/n");
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息