您的位置:首页 > 其它

POJ 1579 Function Run Fun 记忆化递归

2010-12-15 21:04 585 查看
 

本题使用记忆话递归即可,也可以用动态规划DP
不过得使用三维数组,空间复杂度比较高
Function Run Fun

Time Limit: 1000MS Memory Limit: 10000
Description
We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

/* Author yan
*POJ 1579
*Function Run Fun
*/
#include<stdio.h>
int value[61][61][61];
int w(int a,int b,int c)
{
if(value[a+10][b+10][c+10]!=-1) return value[a+10][b+10][c+10];
else
{
if(a<=0||b<=0||c<=0) return value[a+10][b+10][c+10]=1;
else if(a>20||b>20||c>20) return value[a+10][b+10][c+10]=w(20,20,20);
else if(a<b&&b<c) return value[a+10][b+10][c+10]=w(a,b,c-1)+w(a,b-1,c-1)-w(a,b-1,c);
else return value[a+10][b+10][c+10]=w(a-1,b,c)+w(a-1,b-1,c)+w(a-1,b,c-1)-w(a-1,b-1,c-1);
}
}
int main()
{
int a,b,c;
//freopen("input","r",stdin);
while(scanf("%d %d %d",&a,&b,&c)&&(a!=-1||b!=-1||c!=-1))
{
memset(value,-1,sizeof(value));
//printf("%d %d %d/n",a,b,c);
printf("w(%d, %d, %d) = ",a,b,c);
if(a<=0||b<=0||c<=0) printf("%d/n",1);
else
{
w(a,b,c);
printf("%d/n",value[a+10][b+10][c+10]);
}
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息