您的位置:首页 > 其它

PKUOJ1579 Function Run Fun

2010-12-08 21:40 423 查看
 

Function Run Fun

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9536 Accepted: 5006
Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output

Print the value for w(a,b,c) for each triple.
Sample Input

1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1

Sample Output

w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1

Source

Pacific Northwest 1999
 

 

 【思路】用一个数组记录已经算过的值,记忆化搜索!

 

 

#include<iostream>
using namespace std;
#define max(x,y) ((x)>(y)?(x):(y))
int ww[21][21][21];
int w(int a,int b,int c)
{
if(a<=0 || b<=0 || c<=0)
return 1;
else if(a>20 || b>20 || c>20)
{
return w(20,20,20);
}
else if(a<b && b<c)
{
if(!ww[a][b][c])
ww[a][b][c] = w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c);
}
else
{
if(!ww[a][b][c])
ww[a][b][c] = w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1);
}
return ww[a][b][c];
}
int main()
{
//ifstream cin("test.txt");
int a,b,c;
memset(ww,0,sizeof(ww));
while(cin>>a>>b>>c)
{
if(a==-1 && b==-1 && c==-1) break;
printf("w(%d, %d, %d) = %d/n",a,b,c,w(a,b,c));
}
return 0;
}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息